Telfort naar KPN Migratie

Intro

Kreeg onlangs van KPN een mail waarin werd aangekondigd dat binnenkort de ‘oude’ Telfort verbinding wordt omgezet naar KPN. Dit betekent dat er wat wijzigingen gemaakt moeten worden in de Edgerouter configuratie. De wijzigingen die ik hieronder doe hebben betrekking om mijn vorige artikel over het instellen van een Edgerouter op Telfort Glasvezel + IPTV.

Ik split deze migratie op in twee gedeeltes. IPv4 en IPv6 waar bij een minimale migratie alleen de stappen voor IPv4 gevolgd hoeven te worden. IPv6 als je IPv6 adressen toegewezen wilt krijgen.

De IPTV instellingen blijven ongewijzigd, deze zijn hetzelfde als het Telfort netwerk.

Table of Contents

IPv4

Verwijder vif 34 en creëer vif 6 op eth0

configure

delete interfaces ethernet eth0 vif 34
set interfaces ethernet eth0 vif 6
set interfaces ethernet eth0 vif 6 description FTTH

commit

Set MTU op eth0 en vif 6

set interfaces ethernet eth0 mtu 1512
set interfaces ethernet eth0 vif 6 mtu 1508

Creëer pppoe0

set interfaces ethernet eth0 vif 6 pppoe 0 default-route auto
set interfaces ethernet eth0 vif 6 pppoe 0 description Internet
set interfaces ethernet eth0 vif 6 pppoe 0 name-server auto
set interfaces ethernet eth0 vif 6 pppoe 0 password internet
set interfaces ethernet eth0 vif 6 pppoe 0 user-id internet
set interfaces ethernet eth0 vif 6 pppoe 0 firewall in name WAN_IN
set interfaces ethernet eth0 vif 6 pppoe 0 firewall local name WAN_LOCAL
set interfaces ethernet eth0 vif 6 pppoe 0 mtu 1500

commit

Wijzig NAT interface naar pppoe0

Let op! dit is bij mij 5001, maar in veel gevallen 5010. Check dit simpel door het volgende commando uit te voeren:

show nat rules|grep eth0.34
set service nat rule 5001 outbound-interface pppoe0

Wijzig port forwarding interface naar pppoe0

set port-forward wan-interface pppoe0

Schakel IPv4 offloading in

set system offload ipv4 forwarding enable
set system offload ipv4 pppoe enable
set system offload ipv4 vlan enable

commit
save

IPv6

Schakel IPv6 in op pppoe0

configure

set interfaces ethernet eth0 vif 6 pppoe 0 ipv6 enable
set interfaces ethernet eth0 vif 6 pppoe 0 ipv6 address autoconf
set interfaces ethernet eth0 vif 6 pppoe 0 ipv6 dup-addr-detect-transmits 1

commit

Schakel IPv6 firewall in

set interfaces ethernet eth0 vif 6 pppoe 0 firewall in ipv6-name WANv6_IN
set interfaces ethernet eth0 vif 6 pppoe 0 firewall local ipv6-name WANv6_LOCAL

Schakel dhcpv6 prefix delegation in op pppoe0 (Let op! br0 is mijn LAN interface)

set interfaces ethernet eth0 vif 6 pppoe 0 dhcpv6-pd pd 0 interface br0 prefix-id :1
set interfaces ethernet eth0 vif 6 pppoe 0 dhcpv6-pd pd 0 interface br0 service slaac
set interfaces ethernet eth0 vif 6 pppoe 0 dhcpv6-pd pd 0 prefix-length /48
set interfaces ethernet eth0 vif 6 pppoe 0 dhcpv6-pd rapid-commit disable

Maak een IPv6 default route aan op pppoe0

set protocols static interface-route6 ::/0 next-hop-interface pppoe0

Router advert instellen op LAN interface. Let op! dit is bij mij br0

set interfaces bridge br0 ipv6 dup-addr-detect-transmits 1
set interfaces bridge br0 ipv6 router-advert cur-hop-limit 64
set interfaces bridge br0 ipv6 router-advert link-mtu 0
set interfaces bridge br0 ipv6 router-advert managed-flag false
set interfaces bridge br0 ipv6 router-advert max-interval 600
set interfaces bridge br0 ipv6 router-advert name-server 2a02:a47f:e000::53
set interfaces bridge br0 ipv6 router-advert name-server 2a02:a47f:e000::54
set interfaces bridge br0 ipv6 router-advert other-config-flag false
set interfaces bridge br0 ipv6 router-advert radvd-options "RDNSS 2a02:a47f:e000::53 2a02:a47f:e000::54 {};"
set interfaces bridge br0 ipv6 router-advert reachable-time 0
set interfaces bridge br0 ipv6 router-advert retrans-timer 0
set interfaces bridge br0 ipv6 router-advert send-advert true
set interfaces bridge br0 ipv6 router-advert prefix ::/64 autonomous-flag true
set interfaces bridge br0 ipv6 router-advert prefix ::/64 on-link-flag true
set interfaces bridge br0 ipv6 router-advert prefix ::/64 valid-lifetime 2592000

IPv6 offloading inschakelen

set system offload ipv6 forwarding enable
set system offload ipv6 pppoe enable

En IPv6-ICMP naar WANv6-IN toestaan

set firewall ipv6-name WANv6_IN rule 30 action accept
set firewall ipv6-name WANv6_IN rule 30 description "Allow IPv6 icmp"
set firewall ipv6-name WANv6_IN rule 30 protocol ipv6-icmp

commit
save

Test of IPv4 en IPv6 werkt via deze link

en_USEnglish